transaction transaction transaction


Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 31    Accepted Submission(s): 15



Problem Description


Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in i t city. Kelukin will take taxi, whose price is 1 yuan per km and this fare cannot be ignored.
There are n−1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.


 



Input


T ( 1≤T≤10) , the number of test cases.
For each test case:
first line contains an integer n ( 2≤n≤100000) means the number of cities;
second line contains n numbers, the i th number means the prices in i th city; (1≤Price≤10000)
then follows n−1 lines, each contains three numbers x, y and z which means there exists a road between x and y, the distance is z km (1≤z≤1000).


 



Output


For each test case, output a single number in a line: the maximum money he can get.


 



Sample Input


1 4 10 40 15 30 1 2 30 1 3 2 3 4 10


 



Sample Output


8


 



Source


2017 ACM/ICPC Asia Regional Shenyang Online 


【题意】:

给出一个无向图,求从某一点到另一点的可以获得的最大利润。利润=汇点-路长-源点。

【解析】:

误打误撞,跑了n次spfa就过了。

【代码】:


#include <stdio.h>
#include <stdlib.h>  
#include <string.h>  
#include <iostream>  
#include <algorithm> 
#include <queue>  
#define mset(a,i) memset(a,i,sizeof(a))
using namespace std;
typedef long long ll;
struct node{
    int to,val,next;
}e[201010];
int n,m,x,y,val,cnt;
int head[100101];
ll dis[101001];
int a[120000];
void add(int x,int y,int v)
{
    e[cnt]=(node){ y,v,head[x] } ; 
    head[x]=cnt++;
}
void SPFA(int s)
{
    queue<int>Q;
    Q.push(s);
    while(!Q.empty())
     {
        int u=Q.front();
        Q.pop();
        for(int i=head[u];~i;i=e[i].next)
        {
            int v=e[i].to;
            if(dis[v]<dis[u]-a[u]+a[v]-e[i].val)
            {
                dis[v]=dis[u]-a[u]+a[v]-e[i].val;
                Q.push(v);
           }
        }
   }
}
int main() 
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		mset(head,-1);
		mset(dis,0);
		cnt=0;
		scanf("%d",&n) ;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
	    for(int i=1;i<=n-1;i++)
	    {
	    	scanf("%d%d%d",&x,&y,&val);
			add(x,y,val);
	    	add(y,x,val);
		}
	    for(int i=1;i<=n;i++)
	    {
	  		SPFA(i);
		}
		ll ans=0;
		for(int i=1;i<=n;i++)
		{
			ans=max(ans,dis[i]);
		}
		printf("%lld\n",ans);
	}
    return 0 ;  
}




阿里云国内75折 回扣 微信号:monov8
阿里云国际,腾讯云国际,低至75折。AWS 93折 免费开户实名账号 代冲值 优惠多多 微信号:monov8 飞机:@monov6