Description


Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?


Input


The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.


Output


For each test of the input, print a line containing the least robots needed.


Sample Input


1 0 2 1 1 2 2 0 0 0


Sample Output


1 1 2


Source


POJ Monthly--2005.08.28,Li Haoyuan


    本题是很明显的最小路径覆盖,但是,一般的最小路径覆盖要求每个顶点只和一条边相关,而这里每个顶点可以走不止一次,因此我们必须做一次传递闭包,把边的连通性传下去。
 

#include<stdio.h>
#include<string.h>

const int maxn=505;

int mat[maxn][maxn];
int mark[maxn];
bool used[maxn];
int n;

void floyd()
{
	for(int k=1;k<=n;k++)
	  for(int i=1;i<=n;i++)
	    for(int j=1;j<=n;j++)
	      mat[i][j]=mat[i][j]||(mat[i][k]&&mat[k][j]);
}

bool dfs(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(mat[x][i] && !used[i])
		{
			used[i]=1;
			if(mark[i]==-1 || dfs(mark[i]))
			{
				mark[i]=x;
				return true;
			}
		}
	}
	return false;
}

int hungary()
{
	memset(mark,-1,sizeof(mark));
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		memset(used,0,sizeof(used));
		if(dfs(i))
		  ans++;
	}
	return ans;
}

int main()
{
	int m;
	while(~scanf("%d%d",&n,&m))
	{
		if(n==0 &&m==0)
		  break;
		int x,y;
		memset(mat,0,sizeof(mat));
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			mat[x][y]=1;
		}
		floyd();
		/*for(int i=1;i<=n;i++)
		  for(int j=1;j<=n;j++)
		    if(mat[i][j])
		      printf("%d--%d\n",i,j);*/
		printf("%d\n",n-hungary());
	}
	return 0;
}





阿里云国内75折 回扣 微信号:monov8
阿里云国际,腾讯云国际,低至75折。AWS 93折 免费开户实名账号 代冲值 优惠多多 微信号:monov8 飞机:@monov6